このエントリーをはてなブックマークに追加

更新日: 2016年2月25日

実行時間: 0.0212

Smarty連携

 この章では、CodeIgniterフレームワークのビューの処理を「Smarty」に置き換える手法を解説していきます。
 現在(2012/03)、Smartyのバージョンは「3.x」系と「2.x」系がリリースされておりますが、「Smarty 3.x」系は 対応するPHPのバージョンが「5.2」以上となっているため、 Smartyをインストールする前に、PHPのバージョンを確認する必要があります。
 CodeIgniterにSmartyをインストールする方法は「3.x」系、「2.x」系共に違いはありません。

キャッシング

 この章では、CodeIgniterにデフォルトで包含されている3つのキャッシュドライバについて解説していきます。
  • APC
  • Memcached
  • ファイルベース
 また、APC、Memcachedを利用するための PHPモジュールのインストール・設定方法の例も示しています。